{"_id":"5cd171dc2db1d80015b8b6f7","project":"5b0e13ffc4664e0003c75a66","version":{"_id":"5b0e13ffc4664e0003c75a67","project":"5b0e13ffc4664e0003c75a66","__v":4,"createdAt":"2015-09-17T16:58:03.490Z","releaseDate":"2015-09-17T16:58:03.490Z","categories":["5b0e13ffc4664e0003c75a68","5b0e13ffc4664e0003c75a69","5b0e13ffc4664e0003c75a6a","5b0e13ffc4664e0003c75a6b","5b0e13ffc4664e0003c75a6c","5b0e13ffc4664e0003c75a6d","5b0e13ffc4664e0003c75a6e","5b0e13ffc4664e0003c75a6f","5b0e13ffc4664e0003c75a70","5b0e13ffc4664e0003c75a71","5b0e13ffc4664e0003c75a72","5b0e13ffc4664e0003c75a73","5b0e13ffc4664e0003c75a74","5b0e13ffc4664e0003c75a75","5b0e13ffc4664e0003c75a76","5b0e13ffc4664e0003c75a77","5b0e13ffc4664e0003c75a89","5b0e13ffc4664e0003c75a8a","5b0e13ffc4664e0003c75a9d","5b0e13ffc4664e0003c75a9e","5b0e13ffc4664e0003c75a9f","5b0e13ffc4664e0003c75aa0","5b0e13ffc4664e0003c75aa1","5b0e13ffc4664e0003c75aa2","5b0e13ffc4664e0003c75aa3","5b0e13ffc4664e0003c75aa4","5b0e13ffc4664e0003c75aa5","5b0e13ffc4664e0003c75aa6","5b0e13ffc4664e0003c75aa7","5b0e13ffc4664e0003c75aa8","5b0e13ffc4664e0003c75aa9","5b0e13ffc4664e0003c75aaa","5b0e13ffc4664e0003c75aab","5b0e13ffc4664e0003c75aac","5b0e13ffc4664e0003c75aad","5b0e13ffc4664e0003c75aae","5b0e13ffc4664e0003c75aaf","5b0e13ffc4664e0003c75ab2","5bb3374f4306ad0003eb18e7","5bbf3c5373e72a000318362b","5bc065567d1cb0000384c649","5cbf19a5f9181f0033fbb968"],"is_deprecated":false,"is_hidden":false,"is_beta":true,"is_stable":true,"codename":"","version_clean":"1.0.0","version":"1.0"},"category":{"_id":"5b0e13ffc4664e0003c75aad","project":"5b0e13ffc4664e0003c75a66","version":"5b0e13ffc4664e0003c75a67","__v":0,"sync":{"url":"","isSync":false},"reference":false,"createdAt":"2017-04-18T08:58:21.978Z","from_sync":false,"order":38,"slug":"data-cruncher","title":"DATA CRUNCHER"},"user":"566590c83889610d0008a253","__v":0,"parentDoc":null,"metadata":{"title":"","description":"","image":[]},"updates":[],"next":{"pages":[],"description":""},"createdAt":"2019-05-07T11:54:04.225Z","link_external":false,"link_url":"","sync_unique":"","hidden":false,"api":{"results":{"codes":[]},"settings":"","auth":"required","params":[],"url":""},"isReference":false,"order":3,"body":"This page provides a brief description of the RStudio IDE and its commonly used options. \n[block:callout]\n{\n  \"type\": \"info\",\n  \"body\": \"RStudio implementation in Data Cruncher is currently in the beta stage. Please report any issues to [support:::at:::sbgenomics.com](mailto:support@sbgenomics.com).\"\n}\n[/block]\n## The RStudio Interface\nOnce you have set up and started an analysis using RStudio as the editor, the main editor screen is displayed. To start entering your R code, select **File** > **New File** from the main menu, and then select the most suitable file type. Alternatively, you can type your code directly in the **Console** pane.\n\nThis is the default RStudio screen setup with an R file open for editing:\n[block:image]\n{\n  \"images\": [\n    {\n      \"image\": [\n        \"https://files.readme.io/a6acb16-rstudio-quick-reference-1.png\",\n        \"rstudio-quick-reference-1.png\",\n        1440,\n        687,\n        \"#f7f5ef\"\n      ]\n    }\n  ]\n}\n[/block]\n1. **Main menu** - complete set of options available in the RStudio IDE.\n2. **Toolbar** - contains buttons for commonly used commands in RStudio.\n3. **Source** - the main editor window where you can create or open your R scripts/notebooks.\n4. **Environment**, **History**, **Connections**:\n    a. **Environment** - shows all active objects created during your session.\n    b. **History** - keeps a record of all previously entered commands.\n    c. **Connections** - shows you all the connections you have made to supported data sources, and lets you know which connections are currently active. \n5. **Console** - allows you to type R commands directly and see the output.\n6. **Files**, **Plots**, **Packages**, **Help**, **Viewer**:\n    a. **Files** - shows all files and folders in your default workspace.\n    b. **Plots** - shows all your graphs.\n    c. **Packages** - lists a series of packages or add-ons needed to run certain processes.\n    d. **Help** - provides additional learning and reference resources.\n    e. **Viewer** - is similar to the **Plots** tab, but displays HTML output generated by some R functions or Shiny apps.\n7. **Shut down** - Stop the analysis and leave RStudio.\n\nAvailable panes and the appearance of the RStudio environment can be customized using the following options:\n\n  * from the **View** menu on the main menu bar,\n  * using window resizing options in the top-right corner of each window and\n  * by dragging the borders between the panes.","excerpt":"","slug":"rstudio-quick-reference","type":"basic","title":"RStudio quick reference"}

RStudio quick reference


This page provides a brief description of the RStudio IDE and its commonly used options. [block:callout] { "type": "info", "body": "RStudio implementation in Data Cruncher is currently in the beta stage. Please report any issues to [support@sbgenomics.com](mailto:support@sbgenomics.com)." } [/block] ## The RStudio Interface Once you have set up and started an analysis using RStudio as the editor, the main editor screen is displayed. To start entering your R code, select **File** > **New File** from the main menu, and then select the most suitable file type. Alternatively, you can type your code directly in the **Console** pane. This is the default RStudio screen setup with an R file open for editing: [block:image] { "images": [ { "image": [ "https://files.readme.io/a6acb16-rstudio-quick-reference-1.png", "rstudio-quick-reference-1.png", 1440, 687, "#f7f5ef" ] } ] } [/block] 1. **Main menu** - complete set of options available in the RStudio IDE. 2. **Toolbar** - contains buttons for commonly used commands in RStudio. 3. **Source** - the main editor window where you can create or open your R scripts/notebooks. 4. **Environment**, **History**, **Connections**: a. **Environment** - shows all active objects created during your session. b. **History** - keeps a record of all previously entered commands. c. **Connections** - shows you all the connections you have made to supported data sources, and lets you know which connections are currently active. 5. **Console** - allows you to type R commands directly and see the output. 6. **Files**, **Plots**, **Packages**, **Help**, **Viewer**: a. **Files** - shows all files and folders in your default workspace. b. **Plots** - shows all your graphs. c. **Packages** - lists a series of packages or add-ons needed to run certain processes. d. **Help** - provides additional learning and reference resources. e. **Viewer** - is similar to the **Plots** tab, but displays HTML output generated by some R functions or Shiny apps. 7. **Shut down** - Stop the analysis and leave RStudio. Available panes and the appearance of the RStudio environment can be customized using the following options: * from the **View** menu on the main menu bar, * using window resizing options in the top-right corner of each window and * by dragging the borders between the panes.